PPR: ppop is deranged!

David Chappell David.Chappell at trincoll.edu
Wed Aug 23 15:59:39 EDT 2006

Kenneth Tindle writes:
> I have a problem with ppr 1.54, compiled from source on Ubuntu Linux
> 6.06 LTS server.  This means that gcc is at 4.0.3.
> When ppop is run as root, it hangs.  A manual kill is needed to remove
> the process.  It is not a true zombie, a normal kill will work,
> kill -9 is not needed.  I say "hang", meaning there is nothing on
> standard output (no messages.)
> When ppop is run as a user listed in /etc/ppr/acl/ppop.allow, while
> issuing any subcommand, you get "FATAL:[...]pprd is probably not
> running."  pprd is in fact running, of course.
> There is a communication failure between ppop and pprd that I cannot
> solve- but I'll bet it is related to gcc 4.x.
> Anybody have this and fixed it?
I have had two reports so far of problems with PPR 1.54 compiled with 
GCC 4.0.2 or 4.0.3.  I have been running the development version 
compiled with GCC 4.0.3, but I have not tried 1.54 with this compiler.  
I will try it now and let everyone know what I find.

More information about the ppr mailing list